BizTalk360 installation failed: “error status: 1603”

Recently we got a client who was unable to complete the installation of BizTalk360. Although all checks indicated  the prerequisites were met, there was an issue on completing the installation wizard for some reason.

BT360-Prerequisites

In the first step they filled all info for creating the IIS virtual directory and application pool. But for some reason, when going to the next step it failed and stopped the installation process. So they couldn’t get past the first step of the installation.
Running the installation from a command prompt, and making sure an installation log got created (for details on how to create an installation log, have a look at http://www.advancedinstaller.com/user-guide/qa-log.html) reveiled a problem ‘ValidateAppPoolUserCredential failed’.

…..

Action 12:41:54: UpdatePropsWithSelectedWebSite.
Action start 12:41:54: UpdatePropsWithSelectedWebSite.
MSI (c) (84:24) [12:41:54:623]: Invoking remote custom action. DLL: C:\Users\[UserName]\AppData\Local\Temp\2\MSI64AE.tmp, Entrypoint: UpdatePropsWithSelectedWebSite
MSI (c) (84!98) [12:41:54:810]: PROPERTY CHANGE: Adding WEBSITE_DESCRIPTION property. Its value is ‘Default Web Site’.
MSI (c) (84!98) [12:41:54:810]: PROPERTY CHANGE: Adding WEBSITE_PORT property. Its value is ’80’.

MSI (c) (84!98) [12:41:54:810]: PROPERTY CHANGE: Adding WEBSITE_IP property. Its value is ‘*’.
Action ended 12:41:54: UpdatePropsWithSelectedWebSite. Return value 1.
MSI (c) (84:04) [12:41:54:841]: Doing action: ValidateAppPoolUserCredential
Action 12:41:54: ValidateAppPoolUserCredential.
Action start 12:41:54: ValidateAppPoolUserCredential.
MSI (c) (84:64) [12:41:54:841]: Invoking remote custom action. DLL: C:\Users\[UserName]\AppData\Local\Temp\2\MSI658A.tmp, Entrypoint: ValidateAppPoolUserCredential
Action ended 12:41:55: ValidateAppPoolUserCredential. Return value 3.
DEBUG: Error 2896: Executing action ValidateAppPoolUserCredential failed.
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2896. The arguments are: ValidateAppPoolUserCredential, ,
Action ended 12:41:55: WelcomeDlg. Return value 3.
MSI (c) (84:E4) [12:41:55:075]: Doing action: FatalError
Action 12:41:55: FatalError.
Action start 12:41:55: FatalError.
Action 12:41:55: FatalError. Dialog created
Action ended 12:41:59: FatalError. Return value 2.

….

While in the event viewer I found a record with following details:

Product: BizTalk360 — Installation failed.
Windows Installer installed the product. Product Name: BizTalk360. Product Version: 7.1.555.0. Product Language: 1033. Manufacturer: Kovai Ltd. Installation success or error status: 1603.

None of the error messages gave me an idea on what the actual problem would be.
Further investigation has showed me that there were still some role services and features missing… So I enabled following windows role service and features:

  • role services for Web server: IIS 6 compatibility
  • Feature: .NET framework 3.5.1

And that seemed to do the trick. I was able to get past the IIS virtual directory settings of the installation wizard and succesfully installed BizTalk360.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s